p PatchFirst

CVE-2014-7835

CVE-2014-7835

This page contains facts from public vulnerability sources. Check the original advisory before updating.

webservice/upload.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 does not ensure that a file upload is for a private or draft area, which allows remote authenticated users to upload files containing JavaScript, and consequently conduct cross-site scripting (XSS) attacks, by specifying the profile-picture area.

EPSS 1.4% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v2.6.0
    • v2.6.1
    • v2.6.2
    • v2.6.3
    • v2.6.4
    • v2.6.5
    Affected ranges
    • ECOSYSTEM: ≥ 2.6.0, < 2.6.6

    Update to 2.6.6

  • moodle/moodle Packagist

    Versions
    • v2.7.0
    • v2.7.1
    • v2.7.2
    Affected ranges
    • ECOSYSTEM: ≥ 2.7.0, < 2.7.3

    Update to 2.7.3

Original sources

Check your server →