p PatchFirst

CVE-2014-8088

CVE-2014-8088

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The (1) Zend_Ldap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote attackers to bypass authentication via a password starting with a null byte, which triggers an unauthenticated bind.

EPSS 2.5% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • zendframework/zendframework Packagist

    Versions
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.0.6
    • 2.0.7
    • 2.0.8
    Affected ranges
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.99

    Update to 2.0.99

  • zendframework/zendframework Packagist

    Versions
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    Affected ranges
    • ECOSYSTEM: ≥ 2.1.0, < 2.1.99

    Update to 2.1.99

  • zendframework/zendframework Packagist

    Versions
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.8

    Update to 2.2.8

  • zendframework/zendframework Packagist

    Versions
    • 2.3.0
    • 2.3.1
    • 2.3.2
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.3

    Update to 2.3.3

  • zendframework/zendframework1 Packagist

    Versions
    • 1.12.0
    • 1.12.1
    • 1.12.2
    • 1.12.3
    • 1.12.4
    • 1.12.5
    • 1.12.6
    • 1.12.7
    • 1.12.8
    Affected ranges
    • ECOSYSTEM: ≥ 1.12.0, < 1.12.9

    Update to 1.12.9

  • zend-framework Ubuntu:16.04:LTS

    Versions
    • 1.11.11-0ubuntu2
    • 1.11.11-0ubuntu3
    • 1.11.11-0ubuntu3.16.04.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →