CVE-2014-8103
CVE-2014-8103
This page contains facts from public vulnerability sources. Check the original advisory before updating.
X.Org Server (aka xserver and xorg-server) 1.15.0 through 1.16.x before 1.16.3 allows remote authenticated users to cause a denial of service (out-of-bounds read or write) or possibly execute arbitrary code via a crafted length or index value to the (1) sproc_dri3_query_version, (2) sproc_dri3_open, (3) sproc_dri3_pixmap_from_buffer, (4) sproc_dri3_buffer_from_pixmap, (5) sproc_dri3_fence_from_fd, (6) sproc_dri3_fd_from_fence, (7) proc_present_query_capabilities, (8) sproc_present_query_version, (9) sproc_present_pixmap, (10) sproc_present_notify_msc, (11) sproc_present_select_input, or (12) sproc_present_query_capabilities function in the (a) DRI3 or (b) Present extension.
EPSS 3.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
xorg-server Debian:12
- Affected ranges
- ECOSYSTEM: < 2:1.16.2.901-1
Update to 2:1.16.2.901-1
xorg-server Debian:13
- Affected ranges
- ECOSYSTEM: < 2:1.16.2.901-1
Update to 2:1.16.2.901-1
xorg-server Debian:14
- Affected ranges
- ECOSYSTEM: < 2:1.16.2.901-1
Update to 2:1.16.2.901-1
xorg-server Ubuntu:14.04:LTS
- Versions
- 2:1.14.3-3ubuntu2
- 2:1.14.3-3ubuntu3
- 2:1.14.3-3ubuntu4
- 2:1.14.3-5ubuntu1
- 2:1.14.4-1ubuntu1
- 2:1.14.4-1ubuntu2
- 2:1.14.4.901-0ubuntu2
- 2:1.14.5-1ubuntu2
- 2:1.14.5-1ubuntu4
- 2:1.15.0-1ubuntu1
- 2:1.15.0-1ubuntu2
- 2:1.15.0-1ubuntu3
- 2:1.15.0-1ubuntu4
- 2:1.15.0-1ubuntu6
- 2:1.15.0-1ubuntu7
- 2:1.15.1-0ubuntu1
- 2:1.15.1-0ubuntu2
- 2:1.15.1-0ubuntu2.1
- Affected ranges
- ECOSYSTEM: < 2:1.15.1-0ubuntu2.4
Update to 2:1.15.1-0ubuntu2.4