CVE-2014-8542
CVE-2014-8542
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libavcodec/utils.c in FFmpeg before 2.4.2 omits a certain codec ID during enforcement of alignment, which allows remote attackers to cause a denial of service (out-of-bounds access) or possibly have unspecified other impact via crafted JV data.
EPSS 2.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ffmpeg Debian:12
- Affected ranges
- ECOSYSTEM: < 7:2.4.3-1
Update to 7:2.4.3-1
ffmpeg Debian:13
- Affected ranges
- ECOSYSTEM: < 7:2.4.3-1
Update to 7:2.4.3-1
ffmpeg Debian:14
- Affected ranges
- ECOSYSTEM: < 7:2.4.3-1
Update to 7:2.4.3-1
libav Ubuntu:14.04:LTS
- Versions
- 6:0.8.7-1ubuntu2
- 6:9.10-1ubuntu1
- 6:9.10-1ubuntu2
- 6:9.10-1ubuntu5
- 6:9.10-1ubuntu6
- 6:9.10-1ubuntu7
- 6:9.11-2ubuntu1
- 6:9.11-2ubuntu2
- 6:9.13-0ubuntu0.14.04.1
- 6:9.14-0ubuntu0.14.04.1
- 6:9.16-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 6:9.18-0ubuntu0.14.04.1
Update to 6:9.18-0ubuntu0.14.04.1
Original sources
- http://git.videolan.org/?p=ffmpeg.git%3Ba=commit%3Bh=105654e376a736d243aef4a1d121abebce912e6b
- http://www.ubuntu.com/usn/USN-2534-1
- https://lists.debian.org/debian-lts-announce/2019/02/msg00005.html
- http://www.ffmpeg.org/security.html
- https://security.gentoo.org/glsa/201603-06
- https://nvd.nist.gov/vuln/detail/CVE-2014-8542