CVE-2014-8595
CVE-2014-8595
This page contains facts from public vulnerability sources. Check the original advisory before updating.
arch/x86/x86_emulate/x86_emulate.c in Xen 3.2.1 through 4.4.x does not properly check privileges, which allows local HVM guest users to gain privileges or cause a denial of service (crash) via a crafted (1) CALL, (2) JMP, (3) RETF, (4) LCALL, (5) LJMP, or (6) LRET far branch instruction.
EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.4.1-4
Update to 4.4.1-4
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.4.1-4
Update to 4.4.1-4
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.4.1-4
Update to 4.4.1-4
xen Ubuntu:14.04:LTS
- Versions
- 4.3.0-1ubuntu1
- 4.3.0-1ubuntu2
- 4.3.0-1ubuntu3
- 4.3.0-1ubuntu4
- 4.3.0-1ubuntu5
- 4.4.0-0ubuntu3
- 4.4.0-0ubuntu4
- 4.4.0-0ubuntu5
- 4.4.0-0ubuntu5.1
- 4.4.0-0ubuntu5.2
- 4.4.1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 4.4.1-0ubuntu0.14.04.2
Update to 4.4.1-0ubuntu0.14.04.2
Original sources
- https://security.gentoo.org/glsa/201504-04
- http://secunia.com/advisories/62672
- http://support.citrix.com/article/CTX201794
- http://support.citrix.com/article/CTX200288
- http://www.debian.org/security/2015/dsa-3140
- http://secunia.com/advisories/62537
- http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00005.html
- http://www.securityfocus.com/bid/71151
- http://xenbits.xen.org/xsa/advisory-110.html
- http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00010.html
- https://exchange.xforce.ibmcloud.com/vulnerabilities/98768
- https://nvd.nist.gov/vuln/detail/CVE-2014-8595