p PatchFirst

CVE-2014-9029

CVE-2014-9029

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple off-by-one errors in the (1) jpc_dec_cp_setfromcox and (2) jpc_dec_cp_setfromrgn functions in jpc/jpc_dec.c in JasPer 1.900.1 and earlier allow remote attackers to execute arbitrary code via a crafted jp2 file, which triggers a heap-based buffer overflow.

EPSS 18.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • jasper Ubuntu:14.04:LTS

    Versions
    • 1.900.1-14
    • 1.900.1-14ubuntu3
    Affected ranges
    • ECOSYSTEM: < 1.900.1-14ubuntu3.1

    Update to 1.900.1-14ubuntu3.1

Original sources

Check your server →