CVE-2014-9221
CVE-2014-9221
This page contains facts from public vulnerability sources. Check the original advisory before updating.
strongSwan 4.5.x through 5.2.x before 5.2.1 allows remote attackers to cause a denial of service (invalid pointer dereference) via a crafted IKEv2 Key Exchange (KE) message with Diffie-Hellman (DH) group 1025.
EPSS 3.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
strongswan Debian:12
- Affected ranges
- ECOSYSTEM: < 5.2.1-5
Update to 5.2.1-5
strongswan Debian:13
- Affected ranges
- ECOSYSTEM: < 5.2.1-5
Update to 5.2.1-5
strongswan Debian:14
- Affected ranges
- ECOSYSTEM: < 5.2.1-5
Update to 5.2.1-5
strongswan Ubuntu:14.04:LTS
- Versions
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- Affected ranges
- ECOSYSTEM: < 5.1.2-0ubuntu2.2
Update to 5.1.2-0ubuntu2.2
Original sources
- http://secunia.com/advisories/62095
- http://strongswan.org/blog/2015/01/05/strongswan-denial-of-service-vulnerability-%28cve-2014-9221%29.html
- http://www.ubuntu.com/usn/USN-2450-1
- http://www.debian.org/security/2015/dsa-3118
- http://secunia.com/advisories/62071
- http://lists.fedoraproject.org/pipermail/package-announce/2015-March/153825.html
- http://secunia.com/advisories/62663
- http://lists.opensuse.org/opensuse-updates/2015-01/msg00054.html
- http://strongswan.org/blog/2015/01/05/strongswan-5.2.2-released.html
- http://secunia.com/advisories/62083
- http://www.securityfocus.com/bid/71894
- https://nvd.nist.gov/vuln/detail/CVE-2014-9221