p PatchFirst

CVE-2014-9295

CVE-2014-9295

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple stack-based buffer overflows in ntpd in NTP before 4.2.8 allow remote attackers to execute arbitrary code via a crafted packet, related to (1) the crypto_recv function when the Autokey Authentication feature is used, (2) the ctl_putdata function, and (3) the configure function.

EPSS 79.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ntp Debian:11

    Affected ranges
    • ECOSYSTEM: < 1:4.2.6.p5+dfsg-3.2

    Update to 1:4.2.6.p5+dfsg-3.2

  • ntp Ubuntu:14.04:LTS

    Versions
    • 1:4.2.6.p5+dfsg-3ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1:4.2.6.p5+dfsg-3ubuntu2.14.04.1

    Update to 1:4.2.6.p5+dfsg-3ubuntu2.14.04.1

Original sources

Check your server →