p PatchFirst

CVE-2014-9601

CVE-2014-9601

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Pillow before 2.7.0 allows remote attackers to cause a denial of service via a compressed text chunk in a PNG image that has a large size when it is decompressed.

CVSS 8.7 · High · EPSS 4.6% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • pillow Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.6.1-2

    Update to 2.6.1-2

  • pillow Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.6.1-2

    Update to 2.6.1-2

  • pillow Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.6.1-2

    Update to 2.6.1-2

  • pillow PyPI

    Versions
    • 1.0
    • 1.1
    • 1.2
    • 1.3
    • 1.4
    • 1.5
    • 1.6
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.7.4
    • 1.7.5
    • 1.7.6
    • 1.7.7
    • 1.7.8
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.4.0
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.6.0
    • 2.6.1
    • 2.6.2
    Affected ranges
    • ECOSYSTEM: < 2.7.0

    Update to 2.7.0

  • pillow Ubuntu:14.04:LTS

    Versions
    • 2.2.1-1ubuntu2
    • 2.2.1-2ubuntu1
    • 2.2.1-3ubuntu2
    • 2.2.1-3ubuntu3
    • 2.2.1-3ubuntu4
    • 2.2.1-3ubuntu6
    • 2.3.0-1ubuntu1
    • 2.3.0-1ubuntu2
    • 2.3.0-1ubuntu3
    • 2.3.0-1ubuntu3.2
    • 2.3.0-1ubuntu3.3
    Affected ranges
    • ECOSYSTEM: < 2.3.0-1ubuntu3.4

    Update to 2.3.0-1ubuntu3.4

Original sources

Check your server →