p PatchFirst

CVE-2014-9649

CVE-2014-9649

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the management plugin in RabbitMQ 2.1.0 through 3.4.x before 3.4.1 allows remote attackers to inject arbitrary web script or HTML via the path info to api/, which is not properly handled in an error message.

EPSS 2.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rabbitmq-server Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.4.1-1

    Update to 3.4.1-1

  • rabbitmq-server Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.4.1-1

    Update to 3.4.1-1

  • rabbitmq-server Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.4.1-1

    Update to 3.4.1-1

Original sources

Check your server →