CVE-2015-0270
CVE-2015-0270
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Zend Framework before 2.2.10 and 2.3.x before 2.3.5 has Potential SQL injection in PostgreSQL Zend\Db adapter.
CVSS 9.8 · Critical · EPSS 1.1% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
zend framework
- Versions
- before 2.2.10 and 2.3.x before 2.3.5: Affected
No fix published
zendframework/zendframework Packagist
- Versions
- 2.0.0
- 2.0.0beta4
- 2.0.0beta5
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.0rc6
- 2.0.0rc7
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.2.0
- 2.2.0rc1
- 2.2.0rc2
- 2.2.0rc3
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- Affected ranges
- ECOSYSTEM: < 2.2.10
Update to 2.2.10
zendframework/zendframework Packagist
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.5
Update to 2.3.5
zendframework/zend-db Packagist
- Versions
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.2.0
- 2.2.0rc1
- 2.2.0rc2
- 2.2.0rc3
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- Affected ranges
- ECOSYSTEM: < 2.2.10
Update to 2.2.10
zendframework/zend-db Packagist
- Versions
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- Affected ranges
- ECOSYSTEM: ≥ 2.3.0, < 2.3.5
Update to 2.3.5