p PatchFirst

CVE-2015-0282

CVE-2015-0282

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GnuTLS before 3.1.0 does not verify that the RSA PKCS #1 signature algorithm matches the signature algorithm in the certificate, which allows remote attackers to conduct downgrade attacks via unspecified vectors.

EPSS 1.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gnutls26 Ubuntu:14.04:LTS

    Versions
    • 2.12.23-1ubuntu4
    • 2.12.23-1ubuntu5
    • 2.12.23-12ubuntu1
    • 2.12.23-12ubuntu2
    • 2.12.23-12ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 2.12.23-12ubuntu2.2

    Update to 2.12.23-12ubuntu2.2

Original sources

Check your server →