p PatchFirst

CVE-2015-0559

CVE-2015-0559

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple use-after-free vulnerabilities in epan/dissectors/packet-wccp.c in the WCCP dissector in Wireshark 1.10.x before 1.10.12 and 1.12.x before 1.12.3 allow remote attackers to cause a denial of service (application crash) via a crafted packet, related to the use of packet-scope memory instead of pinfo-scope memory.

EPSS 1.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.12.1+g01b65bf-3

    Update to 1.12.1+g01b65bf-3

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.12.1+g01b65bf-3

    Update to 1.12.1+g01b65bf-3

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.12.1+g01b65bf-3

    Update to 1.12.1+g01b65bf-3

  • wireshark Ubuntu:14.04:LTS

    Versions
    • 1.10.2-1
    • 1.10.3-1
    • 1.10.5-1ubuntu1
    • 1.10.5-2
    • 1.10.6-1
    • 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
    Affected ranges
    • ECOSYSTEM: < 2.6.3-1~ubuntu14.04.1

    Update to 2.6.3-1~ubuntu14.04.1

  • wireshark Ubuntu:16.04:LTS

    Versions
    • 1.12.7+g7fc8978-1
    • 1.12.8+g5b6e543-2
    • 2.0.1+g59ea380-3build1
    • 2.0.2+ga16e22e-1
    • 2.2.6+g32dac6a-2ubuntu0.16.04
    Affected ranges
    • ECOSYSTEM: < 2.6.3-1~ubuntu16.04.1

    Update to 2.6.3-1~ubuntu16.04.1

  • wireshark Ubuntu:18.04:LTS

    Versions
    • 2.4.2-1
    • 2.4.3-1
    • 2.4.4-1
    • 2.4.5-1
    Affected ranges
    • ECOSYSTEM: < 2.6.3-1~ubuntu18.04.1

    Update to 2.6.3-1~ubuntu18.04.1

Original sources

Check your server →