CVE-2015-0852
CVE-2015-0852
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.
EPSS 3.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
freeimage Debian:12
- Affected ranges
- ECOSYSTEM: < 3.15.4-5
Update to 3.15.4-5
freeimage Debian:13
- Affected ranges
- ECOSYSTEM: < 3.15.4-5
Update to 3.15.4-5
freeimage Ubuntu:Pro:14.04:LTS
- Versions
- 3.15.1-2build1
- 3.15.1-2build2
- 3.15.4-2
- 3.15.4-3
- 3.15.4-3ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 3.15.4-3ubuntu0.1+esm1
Update to 3.15.4-3ubuntu0.1+esm1
Original sources
- http://www.securitytracker.com/id/1034077
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/168000.html
- https://www.oracle.com/technetwork/security-advisory/cpujan2019-5072801.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172491.html
- http://www.debian.org/security/2015/dsa-3392
- http://lists.fedoraproject.org/pipermail/package-announce/2015-November/172583.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-October/168023.html
- http://www.openwall.com/lists/oss-security/2015/08/28/1
- http://lists.fedoraproject.org/pipermail/package-announce/2015-September/167766.html
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=797165
- https://security.gentoo.org/glsa/201701-68
- https://nvd.nist.gov/vuln/detail/CVE-2015-0852