CVE-2015-1465
CVE-2015-1465
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The IPv4 implementation in the Linux kernel before 3.18.8 does not properly consider the length of the Read-Copy Update (RCU) grace period for redirecting lookups in the absence of caching, which allows remote attackers to cause a denial of service (memory consumption or system crash) via a flood of packets.
EPSS 6.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
linux Debian:12
- Affected ranges
- ECOSYSTEM: < 3.16.7-ckt7-1
Update to 3.16.7-ckt7-1
linux Debian:13
- Affected ranges
- ECOSYSTEM: < 3.16.7-ckt7-1
Update to 3.16.7-ckt7-1
linux Debian:14
- Affected ranges
- ECOSYSTEM: < 3.16.7-ckt7-1
Update to 3.16.7-ckt7-1
linux Ubuntu:14.04:LTS
- Versions
- 3.11.0-12.19
- 3.12.0-1.3
- 3.12.0-2.5
- 3.12.0-2.7
- 3.12.0-3.8
- 3.12.0-3.9
- 3.12.0-4.10
- 3.12.0-4.12
- 3.12.0-5.13
- 3.12.0-7.15
- 3.13.0-1.16
- 3.13.0-2.17
- 3.13.0-3.18
- 3.13.0-4.19
- 3.13.0-5.20
- 3.13.0-6.23
- 3.13.0-7.25
- 3.13.0-7.26
- 3.13.0-8.27
- 3.13.0-8.28
- 3.13.0-10.30
- 3.13.0-11.31
- 3.13.0-12.32
- 3.13.0-13.33
- 3.13.0-14.34
- 3.13.0-15.35
- 3.13.0-16.36
- 3.13.0-17.37
- 3.13.0-18.38
- 3.13.0-19.39
- 3.13.0-19.40
- 3.13.0-20.42
- 3.13.0-21.43
- 3.13.0-22.44
- 3.13.0-23.45
- 3.13.0-24.46
- 3.13.0-24.47
- 3.13.0-27.50
- 3.13.0-29.53
- 3.13.0-30.54
- 3.13.0-30.55
- 3.13.0-32.57
- 3.13.0-33.58
- 3.13.0-34.60
- 3.13.0-35.62
- 3.13.0-36.63
- 3.13.0-37.64
- 3.13.0-39.66
- 3.13.0-40.69
- 3.13.0-41.70
- 3.13.0-43.72
- 3.13.0-44.73
- 3.13.0-45.74
- 3.13.0-46.75
- 3.13.0-46.76
- 3.13.0-46.77
- 3.13.0-46.79
- 3.13.0-48.80
- Affected ranges
- ECOSYSTEM: < 3.13.0-49.81
Update to 3.13.0-49.81
linux-lts-utopic Ubuntu:14.04:LTS
- Versions
- 3.16.0-25.33~14.04.2
- 3.16.0-26.35~14.04.1
- 3.16.0-28.37~14.04.1
- 3.16.0-28.38~14.04.1
- 3.16.0-29.39~14.04.1
- 3.16.0-30.40~14.04.1
- 3.16.0-31.41~14.04.1
- 3.16.0-31.43~14.04.1
- Affected ranges
- ECOSYSTEM: < 3.16.0-33.44~14.04.1
Update to 3.16.0-33.44~14.04.1
Original sources
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00009.html
- http://www.ubuntu.com/usn/USN-2562-1
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00008.html
- http://www.ubuntu.com/usn/USN-2546-1
- http://www.ubuntu.com/usn/USN-2563-1
- http://lists.opensuse.org/opensuse-security-announce/2015-08/msg00011.html
- http://www.securitytracker.com/id/1036763
- http://www.openwall.com/lists/oss-security/2015/02/03/13
- https://bugzilla.redhat.com/show_bug.cgi?id=1183744
- http://www.ubuntu.com/usn/USN-2545-1
- https://github.com/torvalds/linux/commit/df4d92549f23e1c037e83323aff58a21b3de7fe0
- http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git%3Ba=commit%3Bh=df4d92549f23e1c037e83323aff58a21b3de7fe0
- http://www.securityfocus.com/bid/72435
- http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.8
- https://nvd.nist.gov/vuln/detail/CVE-2015-1465