CVE-2015-1868
CVE-2015-1868
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and 3.7.x before 3.7.2 and Authoritative (Auth) Server 3.2.x, 3.3.x before 3.3.2, and 3.4.x before 3.4.4 allows remote attackers to cause a denial of service (CPU consumption or crash) via a request with a name that refers to itself.
EPSS 78.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
pdns Debian:12
- Affected ranges
- ECOSYSTEM: < 3.4.4-1
Update to 3.4.4-1
pdns Debian:13
- Affected ranges
- ECOSYSTEM: < 3.4.4-1
Update to 3.4.4-1
pdns Debian:14
- Affected ranges
- ECOSYSTEM: < 3.4.4-1
Update to 3.4.4-1
pdns-recursor Debian:12
- Affected ranges
- ECOSYSTEM: < 3.7.2-1
Update to 3.7.2-1
pdns-recursor Debian:13
- Affected ranges
- ECOSYSTEM: < 3.7.2-1
Update to 3.7.2-1
pdns-recursor Debian:14
- Affected ranges
- ECOSYSTEM: < 3.7.2-1
Update to 3.7.2-1
pdns Ubuntu:14.04:LTS
- Versions
- 3.1-4build1
- 3.3-1
- 3.3-2
- Affected ranges
- ECOSYSTEM: < 3.3-2ubuntu0.1
Update to 3.3-2ubuntu0.1
pdns-recursor Ubuntu:14.04:LTS
- Versions
- 3.3-3
- 3.5.3-1
- Affected ranges
- ECOSYSTEM: < 3.5.3-1ubuntu0.1
Update to 3.5.3-1ubuntu0.1
Original sources
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/156648.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/156725.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/156743.html
- http://www.securityfocus.com/bid/74306
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/156655.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/156680.html
- http://www.debian.org/security/2015/dsa-3306
- http://www.debian.org/security/2015/dsa-3307
- http://www.securitytracker.com/id/1032220
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/156667.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-1868