CVE-2015-20109
CVE-2015-20109
This page contains facts from public vulnerability sources. Check the original advisory before updating.
end_pattern (called from internal_fnmatch) in the GNU C Library (aka glibc or libc6) before 2.22 might allow context-dependent attackers to cause a denial of service (application crash), as demonstrated by use of the fnmatch library function with the **(!() pattern. NOTE: this is not the same as CVE-2015-8984; also, some Linux distributions have fixed CVE-2015-8984 but have not fixed this additional fnmatch issue.
CVSS 5.5 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
glibc Debian:12
- Affected ranges
- ECOSYSTEM: < 2.22-1
Update to 2.22-1
glibc Debian:13
- Affected ranges
- ECOSYSTEM: < 2.22-1
Update to 2.22-1
glibc Debian:14
- Affected ranges
- ECOSYSTEM: < 2.22-1
Update to 2.22-1
eglibc Ubuntu:Pro:14.04:LTS
- Versions
- 2.17-93ubuntu4
- 2.18-0ubuntu1
- 2.18-0ubuntu2
- 2.18-0ubuntu4
- 2.18-0ubuntu5
- 2.18-0ubuntu6
- 2.18-0ubuntu7
- 2.19-0ubuntu2
- 2.19-0ubuntu3
- 2.19-0ubuntu4
- 2.19-0ubuntu5
- 2.19-0ubuntu6
- 2.19-0ubuntu6.1
- 2.19-0ubuntu6.3
- 2.19-0ubuntu6.4
- 2.19-0ubuntu6.5
- 2.19-0ubuntu6.6
- 2.19-0ubuntu6.7
- 2.19-0ubuntu6.8
- 2.19-0ubuntu6.9
- 2.19-0ubuntu6.10
- 2.19-0ubuntu6.11
- 2.19-0ubuntu6.13
- 2.19-0ubuntu6.14
- 2.19-0ubuntu6.15
- 2.19-0ubuntu6.15+esm1
- 2.19-0ubuntu6.15+esm2
- Affected ranges
- ECOSYSTEM: < 2.19-0ubuntu6.15+esm3
Update to 2.19-0ubuntu6.15+esm3