p PatchFirst

CVE-2015-2045

CVE-2015-2045

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The HYPERVISOR_xen_version hypercall in Xen 3.2.x through 4.5.x does not properly initialize data structures, which allows local guest users to obtain sensitive information via unspecified vectors.

EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • xen Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.4.1-8

    Update to 4.4.1-8

  • xen Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.4.1-8

    Update to 4.4.1-8

  • xen Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.4.1-8

    Update to 4.4.1-8

  • xen Ubuntu:14.04:LTS

    Versions
    • 4.3.0-1ubuntu1
    • 4.3.0-1ubuntu2
    • 4.3.0-1ubuntu3
    • 4.3.0-1ubuntu4
    • 4.3.0-1ubuntu5
    • 4.4.0-0ubuntu3
    • 4.4.0-0ubuntu4
    • 4.4.0-0ubuntu5
    • 4.4.0-0ubuntu5.1
    • 4.4.0-0ubuntu5.2
    • 4.4.1-0ubuntu0.14.04.1
    • 4.4.1-0ubuntu0.14.04.2
    • 4.4.1-0ubuntu0.14.04.3
    Affected ranges
    • ECOSYSTEM: < 4.4.1-0ubuntu0.14.04.4

    Update to 4.4.1-0ubuntu0.14.04.4

Original sources

Check your server →