p PatchFirst

CVE-2015-2171

CVE-2015-2171

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Middleware/SessionCookie.php in Slim before 2.6.0 allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via crafted session data.

EPSS 2.5% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • slim/slim Packagist

    Versions
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    • 1.6.7
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.5.0
    Affected ranges
    • ECOSYSTEM: < 2.6.0

    Update to 2.6.0

Original sources

Check your server →