CVE-2015-2694
CVE-2015-2694
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The kdcpreauth modules in MIT Kerberos 5 (aka krb5) 1.12.x and 1.13.x before 1.13.2 do not properly track whether a client's request has been validated, which allows remote attackers to bypass an intended preauthentication requirement by providing (1) zero bytes of data or (2) an arbitrary realm name, related to plugins/preauth/otp/main.c and plugins/preauth/pkinit/pkinit_srv.c.
EPSS 2.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
krb5 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.12.1+dfsg-20
Update to 1.12.1+dfsg-20
krb5 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.12.1+dfsg-20
Update to 1.12.1+dfsg-20
krb5 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.12.1+dfsg-20
Update to 1.12.1+dfsg-20
krb5 Ubuntu:14.04:LTS
- Versions
- 1.10.1+dfsg-6.1ubuntu1
- 1.11.3+dfsg-3ubuntu2
- 1.12+dfsg-2ubuntu1
- 1.12+dfsg-2ubuntu2
- 1.12+dfsg-2ubuntu3
- 1.12+dfsg-2ubuntu4
- 1.12+dfsg-2ubuntu4.2
- 1.12+dfsg-2ubuntu5
- 1.12+dfsg-2ubuntu5.1
- Affected ranges
- ECOSYSTEM: < 1.12+dfsg-2ubuntu5.2
Update to 1.12+dfsg-2ubuntu5.2
Original sources
- https://github.com/krb5/krb5/commit/e3b5a5e5267818c97750b266df50b6a3d4649604
- http://www.oracle.com/technetwork/topics/security/linuxbulletinoct2015-2719645.html
- http://www.securityfocus.com/bid/74824
- http://krbdev.mit.edu/rt/Ticket/Display.html?id=8160
- http://www.ubuntu.com/usn/USN-2810-1
- https://nvd.nist.gov/vuln/detail/CVE-2015-2694