p PatchFirst

CVE-2015-2695

CVE-2015-2695

This page contains facts from public vulnerability sources. Check the original advisory before updating.

lib/gssapi/spnego/spnego_mech.c in MIT Kerberos 5 (aka krb5) before 1.14 relies on an inappropriate context handle, which allows remote attackers to cause a denial of service (incorrect pointer read and process crash) via a crafted SPNEGO packet that is mishandled during a gss_inquire_context call.

EPSS 6.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • krb5 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.13.2+dfsg-3

    Update to 1.13.2+dfsg-3

  • krb5 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.13.2+dfsg-3

    Update to 1.13.2+dfsg-3

  • krb5 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.13.2+dfsg-3

    Update to 1.13.2+dfsg-3

  • krb5 Ubuntu:14.04:LTS

    Versions
    • 1.10.1+dfsg-6.1ubuntu1
    • 1.11.3+dfsg-3ubuntu2
    • 1.12+dfsg-2ubuntu1
    • 1.12+dfsg-2ubuntu2
    • 1.12+dfsg-2ubuntu3
    • 1.12+dfsg-2ubuntu4
    • 1.12+dfsg-2ubuntu4.2
    • 1.12+dfsg-2ubuntu5
    • 1.12+dfsg-2ubuntu5.1
    Affected ranges
    • ECOSYSTEM: < 1.12+dfsg-2ubuntu5.2

    Update to 1.12+dfsg-2ubuntu5.2

Original sources

Check your server →