p PatchFirst

CVE-2015-2698

CVE-2015-2698

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The iakerb_gss_export_sec_context function in lib/gssapi/krb5/iakerb.c in MIT Kerberos 5 (aka krb5) 1.14 pre-release 2015-09-14 improperly accesses a certain pointer, which allows remote authenticated users to cause a denial of service (memory corruption) or possibly have unspecified other impact by interacting with an application that calls the gss_export_sec_context function. NOTE: this vulnerability exists because of an incorrect fix for CVE-2015-2696.

EPSS 2.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • krb5 Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.13.2+dfsg-4

    Update to 1.13.2+dfsg-4

  • krb5 Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.13.2+dfsg-4

    Update to 1.13.2+dfsg-4

  • krb5 Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.13.2+dfsg-4

    Update to 1.13.2+dfsg-4

  • krb5 Ubuntu:14.04:LTS

    Versions
    • 1.10.1+dfsg-6.1ubuntu1
    • 1.11.3+dfsg-3ubuntu2
    • 1.12+dfsg-2ubuntu1
    • 1.12+dfsg-2ubuntu2
    • 1.12+dfsg-2ubuntu3
    • 1.12+dfsg-2ubuntu4
    • 1.12+dfsg-2ubuntu4.2
    • 1.12+dfsg-2ubuntu5
    • 1.12+dfsg-2ubuntu5.1
    Affected ranges
    • ECOSYSTEM: < 1.12+dfsg-2ubuntu5.2

    Update to 1.12+dfsg-2ubuntu5.2

Original sources

Check your server →