CVE-2015-2756
CVE-2015-2756
This page contains facts from public vulnerability sources. Check the original advisory before updating.
QEMU, as used in Xen 3.3.x through 4.5.x, does not properly restrict access to PCI command registers, which might allow local HVM guest users to cause a denial of service (non-maskable interrupt and host crash) by disabling the (1) memory or (2) I/O decoding for a PCI Express device and then accessing the device, which triggers an Unsupported Request (UR) response.
EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:2.3+dfsg-3
Update to 1:2.3+dfsg-3
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:2.3+dfsg-3
Update to 1:2.3+dfsg-3
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:2.3+dfsg-3
Update to 1:2.3+dfsg-3
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.2.0~rc2-1
Update to 4.2.0~rc2-1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.2.0~rc2-1
Update to 4.2.0~rc2-1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.2.0~rc2-1
Update to 4.2.0~rc2-1
qemu Ubuntu:14.04:LTS
- Versions
- 1.5.0+dfsg-3ubuntu5
- 1.5.0+dfsg-3ubuntu6
- 1.6.0+dfsg-2ubuntu1
- 1.6.0+dfsg-2ubuntu2
- 1.6.0+dfsg-2ubuntu3
- 1.6.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu1
- 1.7.0+dfsg-2ubuntu2
- 1.7.0+dfsg-2ubuntu3
- 1.7.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu5
- 1.7.0+dfsg-2ubuntu7
- 1.7.0+dfsg-2ubuntu8
- 1.7.0+dfsg-2ubuntu9
- 1.7.0+dfsg-3ubuntu1~ppa1
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- 1.7.0+dfsg-3ubuntu3
- 1.7.0+dfsg-3ubuntu4
- 1.7.0+dfsg-3ubuntu5
- 1.7.0+dfsg-3ubuntu6
- 1.7.0+dfsg-3ubuntu7
- 2.0.0~rc1+dfsg-0ubuntu1
- 2.0.0~rc1+dfsg-0ubuntu2
- 2.0.0~rc1+dfsg-0ubuntu3
- 2.0.0~rc1+dfsg-0ubuntu3.1
- 2.0.0+dfsg-2ubuntu1
- 2.0.0+dfsg-2ubuntu1.1
- 2.0.0+dfsg-2ubuntu1.2
- 2.0.0+dfsg-2ubuntu1.3
- 2.0.0+dfsg-2ubuntu1.5
- 2.0.0+dfsg-2ubuntu1.6
- 2.0.0+dfsg-2ubuntu1.7
- 2.0.0+dfsg-2ubuntu1.8
- 2.0.0+dfsg-2ubuntu1.9
- 2.0.0+dfsg-2ubuntu1.10
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-2ubuntu1.11
Update to 2.0.0+dfsg-2ubuntu1.11
xen Ubuntu:14.04:LTS
- Versions
- 4.3.0-1ubuntu1
- 4.3.0-1ubuntu2
- 4.3.0-1ubuntu3
- 4.3.0-1ubuntu4
- 4.3.0-1ubuntu5
- 4.4.0-0ubuntu3
- 4.4.0-0ubuntu4
- 4.4.0-0ubuntu5
- 4.4.0-0ubuntu5.1
- 4.4.0-0ubuntu5.2
- 4.4.1-0ubuntu0.14.04.1
- 4.4.1-0ubuntu0.14.04.2
- 4.4.1-0ubuntu0.14.04.3
- 4.4.1-0ubuntu0.14.04.4
- Affected ranges
- ECOSYSTEM: < 4.4.1-0ubuntu0.14.04.5
Update to 4.4.1-0ubuntu0.14.04.5
Original sources
- http://www.securityfocus.com/bid/72577
- https://security.gentoo.org/glsa/201504-04
- https://support.citrix.com/article/CTX206006
- http://www.debian.org/security/2015/dsa-3259
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/155198.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/154574.html
- http://support.citrix.com/article/CTX201145
- http://lists.nongnu.org/archive/html/qemu-devel/2015-03/msg06179.html
- http://xenbits.xen.org/xsa/advisory-126.html
- http://lists.opensuse.org/opensuse-security-announce/2015-04/msg00014.html
- http://www.ubuntu.com/usn/USN-2608-1
- http://www.securitytracker.com/id/1031998
- http://lists.fedoraproject.org/pipermail/package-announce/2015-April/154579.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-2756