p PatchFirst

CVE-2015-2933

CVE-2015-2933

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the Html class in MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2 allows remote attackers to inject arbitrary web script or HTML via a LanguageConverter substitution string when using a language variant.

EPSS 2.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.19.20+dfsg-2.3

    Update to 1:1.19.20+dfsg-2.3

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.19.20+dfsg-2.3

    Update to 1:1.19.20+dfsg-2.3

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.19.20+dfsg-2.3

    Update to 1:1.19.20+dfsg-2.3

Original sources

Check your server →