CVE-2015-2937
CVE-2015-2937
This page contains facts from public vulnerability sources. Check the original advisory before updating.
MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM or Zend PHP, allows remote attackers to cause a denial of service ("quadratic blowup" and memory consumption) via an XML file containing an entity declaration with long replacement text and many references to this entity, a different vulnerability than CVE-2015-2942.
EPSS 2.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
mediawiki Debian:12
- Affected ranges
- ECOSYSTEM: < 1:1.19.20+dfsg-2.3
Update to 1:1.19.20+dfsg-2.3
mediawiki Debian:13
- Affected ranges
- ECOSYSTEM: < 1:1.19.20+dfsg-2.3
Update to 1:1.19.20+dfsg-2.3
mediawiki Debian:14
- Affected ranges
- ECOSYSTEM: < 1:1.19.20+dfsg-2.3
Update to 1:1.19.20+dfsg-2.3
Original sources
- https://security.gentoo.org/glsa/201510-05
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:200
- http://www.securityfocus.com/bid/73477
- http://www.openwall.com/lists/oss-security/2015/04/07/3
- http://www.openwall.com/lists/oss-security/2015/04/01/1
- https://lists.wikimedia.org/pipermail/mediawiki-announce/2015-March/000175.html
- https://phabricator.wikimedia.org/T71210
- https://nvd.nist.gov/vuln/detail/CVE-2015-2937