p PatchFirst

CVE-2015-2941

CVE-2015-2941

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.19.24, 1.2x before 1.23.9, and 1.24.x before 1.24.2, when using HHVM, allows remote attackers to inject arbitrary web script or HTML via an invalid parameter in a wddx format request to api.php, which is not properly handled in an error message, related to unsafe calls to wddx_serialize_value.

EPSS 2.1% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mediawiki Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:1.19.20+dfsg-2.3

    Update to 1:1.19.20+dfsg-2.3

  • mediawiki Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:1.19.20+dfsg-2.3

    Update to 1:1.19.20+dfsg-2.3

  • mediawiki Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:1.19.20+dfsg-2.3

    Update to 1:1.19.20+dfsg-2.3

Original sources

Check your server →