CVE-2015-3214
CVE-2015-3214
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The pit_ioport_read in i8254.c in the Linux kernel before 2.6.33 and QEMU before 2.3.1 does not distinguish between read lengths and write lengths, which might allow guest OS users to execute arbitrary code on the host OS by triggering use of an invalid index.
EPSS 1.6% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:2.4+dfsg-1a
Update to 1:2.4+dfsg-1a
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:2.4+dfsg-1a
Update to 1:2.4+dfsg-1a
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:2.4+dfsg-1a
Update to 1:2.4+dfsg-1a
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.4.0-1
Update to 4.4.0-1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.4.0-1
Update to 4.4.0-1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.4.0-1
Update to 4.4.0-1
qemu Ubuntu:14.04:LTS
- Versions
- 1.5.0+dfsg-3ubuntu5
- 1.5.0+dfsg-3ubuntu6
- 1.6.0+dfsg-2ubuntu1
- 1.6.0+dfsg-2ubuntu2
- 1.6.0+dfsg-2ubuntu3
- 1.6.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu1
- 1.7.0+dfsg-2ubuntu2
- 1.7.0+dfsg-2ubuntu3
- 1.7.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu5
- 1.7.0+dfsg-2ubuntu7
- 1.7.0+dfsg-2ubuntu8
- 1.7.0+dfsg-2ubuntu9
- 1.7.0+dfsg-3ubuntu1~ppa1
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- 1.7.0+dfsg-3ubuntu3
- 1.7.0+dfsg-3ubuntu4
- 1.7.0+dfsg-3ubuntu5
- 1.7.0+dfsg-3ubuntu6
- 1.7.0+dfsg-3ubuntu7
- 2.0.0~rc1+dfsg-0ubuntu1
- 2.0.0~rc1+dfsg-0ubuntu2
- 2.0.0~rc1+dfsg-0ubuntu3
- 2.0.0~rc1+dfsg-0ubuntu3.1
- 2.0.0+dfsg-2ubuntu1
- 2.0.0+dfsg-2ubuntu1.1
- 2.0.0+dfsg-2ubuntu1.2
- 2.0.0+dfsg-2ubuntu1.3
- 2.0.0+dfsg-2ubuntu1.5
- 2.0.0+dfsg-2ubuntu1.6
- 2.0.0+dfsg-2ubuntu1.7
- 2.0.0+dfsg-2ubuntu1.8
- 2.0.0+dfsg-2ubuntu1.9
- 2.0.0+dfsg-2ubuntu1.10
- 2.0.0+dfsg-2ubuntu1.11
- 2.0.0+dfsg-2ubuntu1.13
- 2.0.0+dfsg-2ubuntu1.14
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-2ubuntu1.15
Update to 2.0.0+dfsg-2ubuntu1.15
Original sources
- https://support.lenovo.com/product_security/qemu
- https://bugzilla.redhat.com/show_bug.cgi?id=1229640
- https://support.lenovo.com/us/en/product_security/qemu
- https://www.exploit-db.com/exploits/37990/
- https://security.gentoo.org/glsa/201510-02
- https://github.com/torvalds/linux/commit/ee73f656a604d5aa9df86a97102e4e462dd79924
- http://www.debian.org/security/2015/dsa-3348
- http://rhn.redhat.com/errata/RHSA-2015-1508.html
- http://rhn.redhat.com/errata/RHSA-2015-1507.html
- http://mirror.linux.org.au/linux/kernel/v2.6/ChangeLog-2.6.33
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=ee73f656a604d5aa9df86a97102e4e462dd79924
- http://rhn.redhat.com/errata/RHSA-2015-1512.html
- http://www.securitytracker.com/id/1032598
- http://www.securityfocus.com/bid/75273
- http://www.openwall.com/lists/oss-security/2015/06/25/7
- https://www.mail-archive.com/qemu-devel%40nongnu.org/msg304138.html
- https://www.arista.com/en/support/advisories-notices/security-advisories/1180-security-advisory-13
- https://nvd.nist.gov/vuln/detail/CVE-2015-3214