p PatchFirst

CVE-2015-3226

CVE-2015-3226

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

EPSS 2.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:4.2.4-2

    Update to 2:4.2.4-2

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:4.2.4-2

    Update to 2:4.2.4-2

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:4.2.4-2

    Update to 2:4.2.4-2

Original sources

Check your server →