p PatchFirst

CVE-2015-3227

CVE-2015-3227

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The (1) jdom.rb and (2) rexml.rb components in Active Support in Ruby on Rails before 4.1.11 and 4.2.x before 4.2.2, when JDOM or REXML is enabled, allow remote attackers to cause a denial of service (SystemStackError) via a large XML document depth.

EPSS 4.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:4.2.4-2

    Update to 2:4.2.4-2

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:4.2.4-2

    Update to 2:4.2.4-2

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:4.2.4-2

    Update to 2:4.2.4-2

Original sources

Check your server →