CVE-2015-3259
CVE-2015-3259
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Stack-based buffer overflow in the xl command line utility in Xen 4.1.x through 4.5.x allows local guest administrators to gain privileges via a long configuration argument.
EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.6.0-1
Update to 4.6.0-1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.6.0-1
Update to 4.6.0-1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.6.0-1
Update to 4.6.0-1
xen Ubuntu:14.04:LTS
- Versions
- 4.3.0-1ubuntu1
- 4.3.0-1ubuntu2
- 4.3.0-1ubuntu3
- 4.3.0-1ubuntu4
- 4.3.0-1ubuntu5
- 4.4.0-0ubuntu3
- 4.4.0-0ubuntu4
- 4.4.0-0ubuntu5
- 4.4.0-0ubuntu5.1
- 4.4.0-0ubuntu5.2
- 4.4.1-0ubuntu0.14.04.1
- 4.4.1-0ubuntu0.14.04.2
- 4.4.1-0ubuntu0.14.04.3
- 4.4.1-0ubuntu0.14.04.4
- 4.4.1-0ubuntu0.14.04.5
- 4.4.1-0ubuntu0.14.04.6
- 4.4.2-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 4.4.2-0ubuntu0.14.04.2
Update to 4.4.2-0ubuntu0.14.04.2
Original sources
- http://xenbits.xen.org/xsa/advisory-137.html
- http://www.debian.org/security/2015/dsa-3414
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00041.html
- https://security.gentoo.org/glsa/201604-03
- http://lists.opensuse.org/opensuse-security-announce/2015-07/msg00042.html
- http://www.securityfocus.com/bid/75573
- http://www.securitytracker.com/id/1032973
- https://nvd.nist.gov/vuln/detail/CVE-2015-3259