p PatchFirst

CVE-2015-3274

CVE-2015-3274

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in the user_get_user_details function in user/lib.php in Moodle through 2.6.11, 2.7.x before 2.7.9, 2.8.x before 2.8.7, and 2.9.x before 2.9.1 allows remote attackers to inject arbitrary web script or HTML by leveraging absence of an external_format_text call in a web service.

CVSS 6.1 · Medium · EPSS 1.5% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v2.7.0
    • v2.7.1
    • v2.7.2
    • v2.7.3
    • v2.7.4
    • v2.7.5
    • v2.7.6
    • v2.7.7
    • v2.7.8
    Affected ranges
    • ECOSYSTEM: ≥ 2.7.0, < 2.7.9

    Update to 2.7.9

  • moodle/moodle Packagist

    Versions
    • v2.8.0
    • v2.8.1
    • v2.8.2
    • v2.8.3
    • v2.8.4
    • v2.8.5
    • v2.8.6
    Affected ranges
    • ECOSYSTEM: ≥ 2.8.0, < 2.8.7

    Update to 2.8.7

  • moodle/moodle Packagist

    Versions
    • v2.9.0
    Affected ranges
    • ECOSYSTEM: ≥ 2.9.0, < 2.9.1

    Update to 2.9.1

Original sources

Check your server →