CVE-2015-3395
CVE-2015-3395
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The msrle_decode_pal4 function in msrledec.c in Libav before 10.7 and 11.x before 11.4 and FFmpeg before 2.0.7, 2.2.x before 2.2.15, 2.4.x before 2.4.8, 2.5.x before 2.5.6, and 2.6.x before 2.6.2 allows remote attackers to have unspecified impact via a crafted image, related to a pixel pointer, which triggers an out-of-bounds array access.
EPSS 2.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ffmpeg Debian:12
- Affected ranges
- ECOSYSTEM: < 7:2.6.2-1
Update to 7:2.6.2-1
ffmpeg Debian:13
- Affected ranges
- ECOSYSTEM: < 7:2.6.2-1
Update to 7:2.6.2-1
ffmpeg Debian:14
- Affected ranges
- ECOSYSTEM: < 7:2.6.2-1
Update to 7:2.6.2-1
chromium-browser Ubuntu:14.04:LTS
- Versions
- 29.0.1547.65-0ubuntu2
- 31.0.1650.63-0ubuntu1~20131204.1
- 32.0.1700.107-0ubuntu1~20140204.977.1
- 33.0.1750.152-0ubuntu1~pkg995.1
- 34.0.1847.116-0ubuntu2
- 36.0.1985.125-0ubuntu1.14.04.0~pkg1029
- 37.0.2062.94-0ubuntu0.14.04.1~pkg1042
- 37.0.2062.120-0ubuntu0.14.04.1~pkg1049
- 38.0.2125.111-0ubuntu0.14.04.1.1061
- 39.0.2171.65-0ubuntu0.14.04.1.1064
- 40.0.2214.94-0ubuntu0.14.04.1.1068
- 40.0.2214.111-0ubuntu0.14.04.1.1069
- 41.0.2272.76-0ubuntu0.14.04.1.1076
- 43.0.2357.81-0ubuntu0.14.04.1.1089
- 43.0.2357.130-0ubuntu0.14.04.1.1092
- 44.0.2403.89-0ubuntu0.14.04.1.1095
- 45.0.2454.85-0ubuntu0.14.04.1.1097
- 45.0.2454.101-0ubuntu0.14.04.1.1099
- Affected ranges
- ECOSYSTEM: < 47.0.2526.73-0ubuntu0.14.04.1.1106
Update to 47.0.2526.73-0ubuntu0.14.04.1.1106
libav Ubuntu:Pro:14.04:LTS
- Versions
- 6:0.8.7-1ubuntu2
- 6:9.10-1ubuntu1
- 6:9.10-1ubuntu2
- 6:9.10-1ubuntu5
- 6:9.10-1ubuntu6
- 6:9.10-1ubuntu7
- 6:9.11-2ubuntu1
- 6:9.11-2ubuntu2
- 6:9.13-0ubuntu0.14.04.1
- 6:9.14-0ubuntu0.14.04.1
- 6:9.16-0ubuntu0.14.04.1
- 6:9.18-0ubuntu0.14.04.1
- 6:9.20-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 6:9.20-0ubuntu0.14.04.1+esm1
Update to 6:9.20-0ubuntu0.14.04.1+esm1
chromium-browser Ubuntu:16.04:LTS
- Versions
- 45.0.2454.101-0ubuntu1.1201
- Affected ranges
- ECOSYSTEM: < 47.0.2526.73-0ubuntu1.1218
Update to 47.0.2526.73-0ubuntu1.1218
Original sources
- https://git.libav.org/?p=libav.git%3Ba=blob%3Bf=Changelog%3Bhb=refs/tags/v11.4
- https://security.gentoo.org/glsa/201705-08
- http://www.ubuntu.com/usn/USN-2944-1
- http://www.debian.org/security/2015/dsa-3288
- http://git.videolan.org/?p=ffmpeg.git%3Ba=commitdiff%3Bh=f7e1367f58263593e6cee3c282f7277d7ee9d553
- https://security.gentoo.org/glsa/201603-06
- http://www.securityfocus.com/bid/74433
- https://www.ffmpeg.org/security.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-3395