CVE-2015-3411
CVE-2015-3411
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PHP before 5.4.40, 5.5.x before 5.5.24, and 5.6.x before 5.6.8 does not ensure that pathnames lack %00 sequences, which might allow remote attackers to read or write to arbitrary files via crafted input to an application that calls (1) a DOMDocument load method, (2) the xmlwriter_open_uri function, (3) the finfo_file function, or (4) the hash_hmac_file function, as demonstrated by a filename\0.xml attack that bypasses an intended configuration in which client users may read only .xml files.
CVSS 6.5 · Medium · EPSS 3.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
php5 Ubuntu:14.04:LTS
- Versions
- 5.5.3+dfsg-1ubuntu2
- 5.5.3+dfsg-1ubuntu3
- 5.5.6+dfsg-1ubuntu1
- 5.5.6+dfsg-1ubuntu2
- 5.5.8+dfsg-2ubuntu1
- 5.5.9+dfsg-1ubuntu1
- 5.5.9+dfsg-1ubuntu2
- 5.5.9+dfsg-1ubuntu3
- 5.5.9+dfsg-1ubuntu4
- 5.5.9+dfsg-1ubuntu4.1
- 5.5.9+dfsg-1ubuntu4.2
- 5.5.9+dfsg-1ubuntu4.3
- 5.5.9+dfsg-1ubuntu4.4
- 5.5.9+dfsg-1ubuntu4.5
- 5.5.9+dfsg-1ubuntu4.6
- 5.5.9+dfsg-1ubuntu4.7
- 5.5.9+dfsg-1ubuntu4.9
- Affected ranges
- ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.11
Update to 5.5.9+dfsg-1ubuntu4.11
Original sources
- http://rhn.redhat.com/errata/RHSA-2015-1187.html
- http://www.securitytracker.com/id/1032709
- http://rhn.redhat.com/errata/RHSA-2015-1186.html
- https://bugs.php.net/bug.php?id=69353
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
- http://git.php.net/?p=php-src.git%3Ba=commit%3Bh=4435b9142ff9813845d5c97ab29a5d637bedb257
- http://php.net/ChangeLog-5.php
- http://www.securityfocus.com/bid/75255
- http://rhn.redhat.com/errata/RHSA-2015-1135.html
- http://rhn.redhat.com/errata/RHSA-2015-1218.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-3411