CVE-2015-3412
CVE-2015-3412
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PHP before 5.4.40, 5.5.x before 5.5.24, and 5.6.x before 5.6.8 does not ensure that pathnames lack %00 sequences, which might allow remote attackers to read arbitrary files via crafted input to an application that calls the stream_resolve_include_path function in ext/standard/streamsfuncs.c, as demonstrated by a filename\0.extension attack that bypasses an intended configuration in which client users may read files with only one specific extension.
CVSS 5.3 · Medium · EPSS 3.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
php5 Ubuntu:14.04:LTS
- Versions
- 5.5.3+dfsg-1ubuntu2
- 5.5.3+dfsg-1ubuntu3
- 5.5.6+dfsg-1ubuntu1
- 5.5.6+dfsg-1ubuntu2
- 5.5.8+dfsg-2ubuntu1
- 5.5.9+dfsg-1ubuntu1
- 5.5.9+dfsg-1ubuntu2
- 5.5.9+dfsg-1ubuntu3
- 5.5.9+dfsg-1ubuntu4
- 5.5.9+dfsg-1ubuntu4.1
- 5.5.9+dfsg-1ubuntu4.2
- 5.5.9+dfsg-1ubuntu4.3
- 5.5.9+dfsg-1ubuntu4.4
- 5.5.9+dfsg-1ubuntu4.5
- 5.5.9+dfsg-1ubuntu4.6
- 5.5.9+dfsg-1ubuntu4.7
- 5.5.9+dfsg-1ubuntu4.9
- Affected ranges
- ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.11
Update to 5.5.9+dfsg-1ubuntu4.11
Original sources
- http://rhn.redhat.com/errata/RHSA-2015-1187.html
- http://www.securitytracker.com/id/1032709
- http://rhn.redhat.com/errata/RHSA-2015-1186.html
- https://bugs.php.net/bug.php?id=69353
- http://www.oracle.com/technetwork/topics/security/linuxbulletinjan2016-2867209.html
- http://git.php.net/?p=php-src.git%3Ba=commit%3Bh=4435b9142ff9813845d5c97ab29a5d637bedb257
- http://php.net/ChangeLog-5.php
- http://rhn.redhat.com/errata/RHSA-2015-1135.html
- http://www.securityfocus.com/bid/75250
- http://rhn.redhat.com/errata/RHSA-2015-1218.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-3412