CVE-2015-4104
CVE-2015-4104
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Xen 3.3.x through 4.5.x does not properly restrict access to PCI MSI mask bits, which allows local x86 HVM guest users to cause a denial of service (unexpected interrupt and host crash) via unspecified vectors.
EPSS 3.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:2.3+dfsg-5
Update to 1:2.3+dfsg-5
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:2.3+dfsg-5
Update to 1:2.3+dfsg-5
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:2.3+dfsg-5
Update to 1:2.3+dfsg-5
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.4.0-1
Update to 4.4.0-1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.4.0-1
Update to 4.4.0-1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.4.0-1
Update to 4.4.0-1
qemu Ubuntu:14.04:LTS
- Versions
- 1.5.0+dfsg-3ubuntu5
- 1.5.0+dfsg-3ubuntu6
- 1.6.0+dfsg-2ubuntu1
- 1.6.0+dfsg-2ubuntu2
- 1.6.0+dfsg-2ubuntu3
- 1.6.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu1
- 1.7.0+dfsg-2ubuntu2
- 1.7.0+dfsg-2ubuntu3
- 1.7.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu5
- 1.7.0+dfsg-2ubuntu7
- 1.7.0+dfsg-2ubuntu8
- 1.7.0+dfsg-2ubuntu9
- 1.7.0+dfsg-3ubuntu1~ppa1
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- 1.7.0+dfsg-3ubuntu3
- 1.7.0+dfsg-3ubuntu4
- 1.7.0+dfsg-3ubuntu5
- 1.7.0+dfsg-3ubuntu6
- 1.7.0+dfsg-3ubuntu7
- 2.0.0~rc1+dfsg-0ubuntu1
- 2.0.0~rc1+dfsg-0ubuntu2
- 2.0.0~rc1+dfsg-0ubuntu3
- 2.0.0~rc1+dfsg-0ubuntu3.1
- 2.0.0+dfsg-2ubuntu1
- 2.0.0+dfsg-2ubuntu1.1
- 2.0.0+dfsg-2ubuntu1.2
- 2.0.0+dfsg-2ubuntu1.3
- 2.0.0+dfsg-2ubuntu1.5
- 2.0.0+dfsg-2ubuntu1.6
- 2.0.0+dfsg-2ubuntu1.7
- 2.0.0+dfsg-2ubuntu1.8
- 2.0.0+dfsg-2ubuntu1.9
- 2.0.0+dfsg-2ubuntu1.10
- 2.0.0+dfsg-2ubuntu1.11
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-2ubuntu1.13
Update to 2.0.0+dfsg-2ubuntu1.13
xen Ubuntu:14.04:LTS
- Versions
- 4.3.0-1ubuntu1
- 4.3.0-1ubuntu2
- 4.3.0-1ubuntu3
- 4.3.0-1ubuntu4
- 4.3.0-1ubuntu5
- 4.4.0-0ubuntu3
- 4.4.0-0ubuntu4
- 4.4.0-0ubuntu5
- 4.4.0-0ubuntu5.1
- 4.4.0-0ubuntu5.2
- 4.4.1-0ubuntu0.14.04.1
- 4.4.1-0ubuntu0.14.04.2
- 4.4.1-0ubuntu0.14.04.3
- 4.4.1-0ubuntu0.14.04.4
- 4.4.1-0ubuntu0.14.04.5
- 4.4.1-0ubuntu0.14.04.6
- 4.4.2-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 4.4.2-0ubuntu0.14.04.2
Update to 4.4.2-0ubuntu0.14.04.2
Original sources
- http://www.ubuntu.com/usn/USN-2630-1
- https://support.citrix.com/article/CTX206006
- http://www.debian.org/security/2015/dsa-3286
- http://lists.opensuse.org/opensuse-security-announce/2015-06/msg00029.html
- http://www.securitytracker.com/id/1032464
- http://lists.fedoraproject.org/pipermail/package-announce/2015-June/160154.html
- http://www.debian.org/security/2015/dsa-3284
- http://lists.opensuse.org/opensuse-security-announce/2015-06/msg00030.html
- http://support.citrix.com/article/CTX201145
- http://lists.opensuse.org/opensuse-security-announce/2015-06/msg00007.html
- https://security.gentoo.org/glsa/201604-03
- http://www.securityfocus.com/bid/74950
- http://xenbits.xen.org/xsa/advisory-129.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-June/160171.html
- http://lists.opensuse.org/opensuse-security-announce/2015-06/msg00004.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-June/160685.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-4104