p PatchFirst

CVE-2015-4105

CVE-2015-4105

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Xen 3.3.x through 4.5.x enables logging for PCI MSI-X pass-through error messages, which allows local x86 HVM guests to cause a denial of service (host disk consumption) via certain invalid operations.

EPSS 0.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • qemu Debian:12

    Affected ranges
    • ECOSYSTEM: < 1:2.3+dfsg-5

    Update to 1:2.3+dfsg-5

  • qemu Debian:13

    Affected ranges
    • ECOSYSTEM: < 1:2.3+dfsg-5

    Update to 1:2.3+dfsg-5

  • qemu Debian:14

    Affected ranges
    • ECOSYSTEM: < 1:2.3+dfsg-5

    Update to 1:2.3+dfsg-5

  • xen Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.4.0-1

    Update to 4.4.0-1

  • xen Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.4.0-1

    Update to 4.4.0-1

  • xen Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.4.0-1

    Update to 4.4.0-1

  • qemu Ubuntu:14.04:LTS

    Versions
    • 1.5.0+dfsg-3ubuntu5
    • 1.5.0+dfsg-3ubuntu6
    • 1.6.0+dfsg-2ubuntu1
    • 1.6.0+dfsg-2ubuntu2
    • 1.6.0+dfsg-2ubuntu3
    • 1.6.0+dfsg-2ubuntu4
    • 1.7.0+dfsg-2ubuntu1
    • 1.7.0+dfsg-2ubuntu2
    • 1.7.0+dfsg-2ubuntu3
    • 1.7.0+dfsg-2ubuntu4
    • 1.7.0+dfsg-2ubuntu5
    • 1.7.0+dfsg-2ubuntu7
    • 1.7.0+dfsg-2ubuntu8
    • 1.7.0+dfsg-2ubuntu9
    • 1.7.0+dfsg-3ubuntu1~ppa1
    • 1.7.0+dfsg-3ubuntu1
    • 1.7.0+dfsg-3ubuntu2
    • 1.7.0+dfsg-3ubuntu3
    • 1.7.0+dfsg-3ubuntu4
    • 1.7.0+dfsg-3ubuntu5
    • 1.7.0+dfsg-3ubuntu6
    • 1.7.0+dfsg-3ubuntu7
    • 2.0.0~rc1+dfsg-0ubuntu1
    • 2.0.0~rc1+dfsg-0ubuntu2
    • 2.0.0~rc1+dfsg-0ubuntu3
    • 2.0.0~rc1+dfsg-0ubuntu3.1
    • 2.0.0+dfsg-2ubuntu1
    • 2.0.0+dfsg-2ubuntu1.1
    • 2.0.0+dfsg-2ubuntu1.2
    • 2.0.0+dfsg-2ubuntu1.3
    • 2.0.0+dfsg-2ubuntu1.5
    • 2.0.0+dfsg-2ubuntu1.6
    • 2.0.0+dfsg-2ubuntu1.7
    • 2.0.0+dfsg-2ubuntu1.8
    • 2.0.0+dfsg-2ubuntu1.9
    • 2.0.0+dfsg-2ubuntu1.10
    • 2.0.0+dfsg-2ubuntu1.11
    Affected ranges
    • ECOSYSTEM: < 2.0.0+dfsg-2ubuntu1.13

    Update to 2.0.0+dfsg-2ubuntu1.13

  • xen Ubuntu:14.04:LTS

    Versions
    • 4.3.0-1ubuntu1
    • 4.3.0-1ubuntu2
    • 4.3.0-1ubuntu3
    • 4.3.0-1ubuntu4
    • 4.3.0-1ubuntu5
    • 4.4.0-0ubuntu3
    • 4.4.0-0ubuntu4
    • 4.4.0-0ubuntu5
    • 4.4.0-0ubuntu5.1
    • 4.4.0-0ubuntu5.2
    • 4.4.1-0ubuntu0.14.04.1
    • 4.4.1-0ubuntu0.14.04.2
    • 4.4.1-0ubuntu0.14.04.3
    • 4.4.1-0ubuntu0.14.04.4
    • 4.4.1-0ubuntu0.14.04.5
    • 4.4.1-0ubuntu0.14.04.6
    • 4.4.2-0ubuntu0.14.04.1
    Affected ranges
    • ECOSYSTEM: < 4.4.2-0ubuntu0.14.04.2

    Update to 4.4.2-0ubuntu0.14.04.2

Original sources

Check your server →