p PatchFirst

CVE-2015-4147

CVE-2015-4147

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The SoapClient::__call method in ext/soap/soap.c in PHP before 5.4.39, 5.5.x before 5.5.23, and 5.6.x before 5.6.7 does not verify that __default_headers is an array, which allows remote attackers to execute arbitrary code by providing crafted serialized data with an unexpected data type, related to a "type confusion" issue.

EPSS 12.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • php5 Ubuntu:14.04:LTS

    Versions
    • 5.5.3+dfsg-1ubuntu2
    • 5.5.3+dfsg-1ubuntu3
    • 5.5.6+dfsg-1ubuntu1
    • 5.5.6+dfsg-1ubuntu2
    • 5.5.8+dfsg-2ubuntu1
    • 5.5.9+dfsg-1ubuntu1
    • 5.5.9+dfsg-1ubuntu2
    • 5.5.9+dfsg-1ubuntu3
    • 5.5.9+dfsg-1ubuntu4
    • 5.5.9+dfsg-1ubuntu4.1
    • 5.5.9+dfsg-1ubuntu4.2
    • 5.5.9+dfsg-1ubuntu4.3
    • 5.5.9+dfsg-1ubuntu4.4
    • 5.5.9+dfsg-1ubuntu4.5
    • 5.5.9+dfsg-1ubuntu4.6
    • 5.5.9+dfsg-1ubuntu4.7
    • 5.5.9+dfsg-1ubuntu4.9
    Affected ranges
    • ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.11

    Update to 5.5.9+dfsg-1ubuntu4.11

Original sources

Check your server →