p PatchFirst

CVE-2015-4164

CVE-2015-4164

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The compat_iret function in Xen 3.1 through 4.5 iterates the wrong way through a loop, which allows local 32-bit PV guest administrators to cause a denial of service (large loop and system hang) via a hypercall_iret call with EFLAGS.VM set.

EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • xen Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.6.0-1

    Update to 4.6.0-1

  • xen Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.6.0-1

    Update to 4.6.0-1

  • xen Debian:14

    Affected ranges
    • ECOSYSTEM: < 4.6.0-1

    Update to 4.6.0-1

  • xen Ubuntu:14.04:LTS

    Versions
    • 4.3.0-1ubuntu1
    • 4.3.0-1ubuntu2
    • 4.3.0-1ubuntu3
    • 4.3.0-1ubuntu4
    • 4.3.0-1ubuntu5
    • 4.4.0-0ubuntu3
    • 4.4.0-0ubuntu4
    • 4.4.0-0ubuntu5
    • 4.4.0-0ubuntu5.1
    • 4.4.0-0ubuntu5.2
    • 4.4.1-0ubuntu0.14.04.1
    • 4.4.1-0ubuntu0.14.04.2
    • 4.4.1-0ubuntu0.14.04.3
    • 4.4.1-0ubuntu0.14.04.4
    • 4.4.1-0ubuntu0.14.04.5
    • 4.4.1-0ubuntu0.14.04.6
    • 4.4.2-0ubuntu0.14.04.1
    Affected ranges
    • ECOSYSTEM: < 4.4.2-0ubuntu0.14.04.2

    Update to 4.4.2-0ubuntu0.14.04.2

Original sources

Check your server →