p PatchFirst

CVE-2015-4171

CVE-2015-4171

This page contains facts from public vulnerability sources. Check the original advisory before updating.

strongSwan 4.3.0 through 5.x before 5.3.2 and strongSwan VPN Client before 1.4.6, when using EAP or pre-shared keys for authenticating an IKEv2 connection, does not enforce server authentication restrictions until the entire authentication process is complete, which allows remote servers to obtain credentials by using a valid certificate and then reading the responses.

EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • strongswan Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.3.1-1

    Update to 5.3.1-1

  • strongswan Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.3.1-1

    Update to 5.3.1-1

  • strongswan Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.3.1-1

    Update to 5.3.1-1

  • strongswan Ubuntu:14.04:LTS

    Versions
    • 4.6.4-9
    • 5.1.0-2
    • 5.1.0-3
    • 5.1.1-0ubuntu1
    • 5.1.1-0ubuntu2
    • 5.1.1-0ubuntu3
    • 5.1.1-0ubuntu4
    • 5.1.1-0ubuntu5
    • 5.1.1-0ubuntu7
    • 5.1.1-0ubuntu14
    • 5.1.1-0ubuntu17
    • 5.1.2~dr3+git20130120-0ubuntu2
    • 5.1.2~dr3+git20130120-0ubuntu3
    • 5.1.2~rc1-0ubuntu3
    • 5.1.2~rc1-0ubuntu4
    • 5.1.2~rc2-0ubuntu2
    • 5.1.2-0ubuntu1
    • 5.1.2-0ubuntu2
    • 5.1.2-0ubuntu2.2
    Affected ranges
    • ECOSYSTEM: < 5.1.2-0ubuntu2.3

    Update to 5.1.2-0ubuntu2.3

  • strongswan Ubuntu:16.04:LTS

    Affected ranges
    • ECOSYSTEM: < 5.1.2-0ubuntu6

    Update to 5.1.2-0ubuntu6

Original sources

Check your server →