p PatchFirst

CVE-2015-4335

CVE-2015-4335

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Redis before 2.8.21 and 3.x before 3.0.2 allows remote attackers to execute arbitrary Lua bytecode via the eval command.

EPSS 9.5% · Fix available

Published
Updated

Stack: system · database

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • redis Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:3.0.2-1

    Update to 2:3.0.2-1

  • redis Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:3.0.2-1

    Update to 2:3.0.2-1

  • redis Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:3.0.2-1

    Update to 2:3.0.2-1

  • redis Ubuntu:14.04:LTS

    Versions
    • 2:2.6.13-1
    • 2:2.6.16-3
    • 2:2.8.0-1
    • 2:2.8.2-1
    • 2:2.8.4-2
    Affected ranges
    • ECOSYSTEM: < 2:2.8.4-2ubuntu0.2

    Update to 2:2.8.4-2ubuntu0.2

Original sources

Check your server →