p PatchFirst

CVE-2015-4706

CVE-2015-4706

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/contents path.

CVSS 6.1 · Medium · EPSS 2.1% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ipython PyPI

    Versions
    • 3.0.0
    • 3.1.0
    Affected ranges
    • ECOSYSTEM: ≥ 3.0.0, < 3.2.0

    Update to 3.2.0

  • ipython PyPI

    Versions
    • 3.0.0
    • 3.1.0
    Affected ranges
    • {"events": [{"introduced": "0"}, {"fixed": "c2078a53543ed502efd968649fee1125e0eb549c"}, {"fixed": "7222bd53ad089a65fd610fab4626f9d0ab47dfce"}], "repo": "https://github.com/ipython/ipython", "type": "GIT"}
    • ECOSYSTEM: ≥ 3.0.0, < 3.2.0

    Update to 3.2.0

Original sources

Check your server →