CVE-2015-5707
CVE-2015-5707
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
Integer overflow in the sg_start_req function in drivers/scsi/sg.c in the Linux kernel 2.6.x through 4.x before 4.1 allows local users to cause a denial of service or possibly have unspecified other impact via a large iov_count value in a write request.
EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
linux Debian:12
- Affected ranges
- ECOSYSTEM: < 4.1.3-1
Update to 4.1.3-1
linux Debian:13
- Affected ranges
- ECOSYSTEM: < 4.1.3-1
Update to 4.1.3-1
linux Debian:14
- Affected ranges
- ECOSYSTEM: < 4.1.3-1
Update to 4.1.3-1
linux Ubuntu:14.04:LTS
- Versions
- 3.11.0-12.19
- 3.12.0-1.3
- 3.12.0-2.5
- 3.12.0-2.7
- 3.12.0-3.8
- 3.12.0-3.9
- 3.12.0-4.10
- 3.12.0-4.12
- 3.12.0-5.13
- 3.12.0-7.15
- 3.13.0-1.16
- 3.13.0-2.17
- 3.13.0-3.18
- 3.13.0-4.19
- 3.13.0-5.20
- 3.13.0-6.23
- 3.13.0-7.25
- 3.13.0-7.26
- 3.13.0-8.27
- 3.13.0-8.28
- 3.13.0-10.30
- 3.13.0-11.31
- 3.13.0-12.32
- 3.13.0-13.33
- 3.13.0-14.34
- 3.13.0-15.35
- 3.13.0-16.36
- 3.13.0-17.37
- 3.13.0-18.38
- 3.13.0-19.39
- 3.13.0-19.40
- 3.13.0-20.42
- 3.13.0-21.43
- 3.13.0-22.44
- 3.13.0-23.45
- 3.13.0-24.46
- 3.13.0-24.47
- 3.13.0-27.50
- 3.13.0-29.53
- 3.13.0-30.54
- 3.13.0-30.55
- 3.13.0-32.57
- 3.13.0-33.58
- 3.13.0-34.60
- 3.13.0-35.62
- 3.13.0-36.63
- 3.13.0-37.64
- 3.13.0-39.66
- 3.13.0-40.69
- 3.13.0-41.70
- 3.13.0-43.72
- 3.13.0-44.73
- 3.13.0-45.74
- 3.13.0-46.75
- 3.13.0-46.76
- 3.13.0-46.77
- 3.13.0-46.79
- 3.13.0-48.80
- 3.13.0-49.81
- 3.13.0-49.83
- 3.13.0-51.84
- 3.13.0-52.85
- 3.13.0-52.86
- 3.13.0-53.88
- 3.13.0-53.89
- 3.13.0-54.91
- 3.13.0-55.92
- 3.13.0-55.94
- 3.13.0-57.95
- 3.13.0-58.97
- 3.13.0-59.98
- 3.13.0-61.100
- 3.13.0-62.102
- Affected ranges
- ECOSYSTEM: < 3.13.0-63.103
Update to 3.13.0-63.103
linux-lts-utopic Ubuntu:14.04:LTS
- Versions
- 3.16.0-25.33~14.04.2
- 3.16.0-26.35~14.04.1
- 3.16.0-28.37~14.04.1
- 3.16.0-28.38~14.04.1
- 3.16.0-29.39~14.04.1
- 3.16.0-30.40~14.04.1
- 3.16.0-31.41~14.04.1
- 3.16.0-31.43~14.04.1
- 3.16.0-33.44~14.04.1
- 3.16.0-34.45~14.04.1
- 3.16.0-34.47~14.04.1
- 3.16.0-36.48~14.04.1
- 3.16.0-37.49~14.04.1
- 3.16.0-37.51~14.04.1
- 3.16.0-38.52~14.04.1
- 3.16.0-39.53~14.04.1
- 3.16.0-40.54~14.04.1
- 3.16.0-41.55~14.04.1
- 3.16.0-41.57~14.04.1
- 3.16.0-43.58~14.04.1
- 3.16.0-44.59~14.04.1
- 3.16.0-45.60~14.04.1
- 3.16.0-46.62~14.04.1
- 3.16.0-48.64~14.04.1
- 3.16.0-49.65~14.04.1
- Affected ranges
- ECOSYSTEM: < 3.16.0-50.66~14.04.1
Update to 3.16.0-50.66~14.04.1
linux-lts-vivid Ubuntu:14.04:LTS
- Versions
- 3.19.0-18.18~14.04.1
- 3.19.0-20.20~14.04.1
- 3.19.0-21.21~14.04.1
- 3.19.0-22.22~14.04.1
- 3.19.0-23.24~14.04.1
- 3.19.0-25.26~14.04.1
- 3.19.0-26.28~14.04.1
- Affected ranges
- ECOSYSTEM: < 3.19.0-28.30~14.04.1
Update to 3.19.0-28.30~14.04.1
Original sources
- http://www.ubuntu.com/usn/USN-2738-1
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00030.html
- http://www.ubuntu.com/usn/USN-2733-1
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=fdc81f45e9f57858da6351836507fbcf1b7583ee
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00029.html
- http://www.ubuntu.com/usn/USN-2750-1
- http://www.ubuntu.com/usn/USN-2737-1
- https://source.android.com/security/bulletin/2017-07-01
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00021.html
- http://www.debian.org/security/2015/dsa-3329
- http://www.securitytracker.com/id/1033521
- https://bugzilla.redhat.com/show_bug.cgi?id=1250030
- https://github.com/torvalds/linux/commit/fdc81f45e9f57858da6351836507fbcf1b7583ee
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=451a2886b6bf90e2fb378f7c46c655450fb96e81
- http://www.ubuntu.com/usn/USN-2760-1
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00032.html
- http://lists.opensuse.org/opensuse-security-announce/2015-09/msg00004.html
- http://www.ubuntu.com/usn/USN-2759-1
- https://github.com/torvalds/linux/commit/451a2886b6bf90e2fb378f7c46c655450fb96e81
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2015-11/msg00027.html
- http://www.ubuntu.com/usn/USN-2734-1
- http://www.openwall.com/lists/oss-security/2015/08/01/6
- https://nvd.nist.gov/vuln/detail/CVE-2015-5707