CVE-2015-6240
CVE-2015-6240
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The chroot, jail, and zone connection plugins in ansible before 1.9.2 allow local users to escape a restricted environment via a symlink attack.
CVSS 8.5 · High · EPSS 0.4% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
ansible Debian:12
- Affected ranges
- ECOSYSTEM: < 1.9.2+dfsg-1
Update to 1.9.2+dfsg-1
ansible Debian:13
- Affected ranges
- ECOSYSTEM: < 1.9.2+dfsg-1
Update to 1.9.2+dfsg-1
ansible Debian:14
- Affected ranges
- ECOSYSTEM: < 1.9.2+dfsg-1
Update to 1.9.2+dfsg-1
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- Affected ranges
- ECOSYSTEM: < 1.9.2
Update to 1.9.2
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- v1.6.0
- v1.4.0
- v1.2
- v1.1
- v1.0
- 0.7
- 0.3
- 0.0.1
- 0.01
- Affected ranges
- {"events": [{"introduced": "0"}, {"fixed": "ca2f2c4ebd7b5e097eab0a710f79c1f63badf95b"}, {"fixed": "952166f48eb0f5797b75b160fd156bbe1e8fc647"}], "repo": "https://github.com/ansible/ansible", "type": "GIT"}
- ECOSYSTEM: < 1.9.2
Update to 1.9.2
ansible Ubuntu:Pro:14.04:LTS
- Versions
- 1.1+dfsg-1
- 1.3.4+dfsg-1
- 1.4.0+dfsg-1
- 1.4.1+dfsg-1
- 1.4.3+dfsg-1
- 1.4.4+dfsg-1
- 1.5.4+dfsg-1
- 1.5.4+dfsg-1ubuntu0.1~esm1
- 1.5.4+dfsg-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: < 1.5.4+dfsg-1ubuntu0.1~esm3
Update to 1.5.4+dfsg-1ubuntu0.1~esm3
Original sources
- https://github.com/ansible/ansible/commit/ca2f2c4ebd7b5e097eab0a710f79c1f63badf95b
- http://www.openwall.com/lists/oss-security/2015/08/17/10
- https://bugzilla.redhat.com/show_bug.cgi?id=1243468
- https://github.com/ansible/ansible/commit/952166f48eb0f5797b75b160fd156bbe1e8fc647
- https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-6240