p PatchFirst

CVE-2015-7337

CVE-2015-7337

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary JavaScript code via a crafted file, which triggers a redirect to files/, related to MIME types.

CVSS 9.8 · Critical · EPSS 2.5% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • notebook PyPI

    Versions
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.0.4
    Affected ranges
    • ECOSYSTEM: ≥ 4.0.0, < 4.0.5

    Update to 4.0.5

  • ipython PyPI

    Versions
    • 0.10
    • 0.10.1
    • 0.10.2
    • 0.11
    • 0.12
    • 0.12.1
    • 0.13
    • 0.13.1
    • 0.13.2
    • 0.6.10
    • 0.6.11
    • 0.6.12
    • 0.6.13
    • 0.6.14
    • 0.6.15
    • 0.6.4
    • 0.6.5
    • 0.6.6
    • 0.6.7
    • 0.6.8
    • 0.6.9
    • 0.7.0
    • 0.7.1
    • 0.7.1.fix1
    • 0.7.2
    • 0.7.3
    • 0.7.4.svn.r2010
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.9
    • 0.9.1
    • 1.0.0
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.3.1
    • 2.4.0
    • 2.4.1
    • 3.0.0
    • 3.1.0
    • 3.2.0
    • 3.2.1
    Affected ranges
    • ECOSYSTEM: < 3.2.2

    Update to 3.2.2

  • ipython PyPI

    Versions
    • 0.10
    • 0.10.1
    • 0.10.2
    • 0.11
    • 0.12
    • 0.12.1
    • 0.13
    • 0.13.1
    • 0.13.2
    • 0.6.10
    • 0.6.11
    • 0.6.12
    • 0.6.13
    • 0.6.14
    • 0.6.15
    • 0.6.4
    • 0.6.5
    • 0.6.6
    • 0.6.7
    • 0.6.8
    • 0.6.9
    • 0.7.0
    • 0.7.1
    • 0.7.1.fix1
    • 0.7.2
    • 0.7.3
    • 0.7.4.svn.r2010
    • 0.8.0
    • 0.8.1
    • 0.8.2
    • 0.8.3
    • 0.8.4
    • 0.9
    • 0.9.1
    • 1.0.0
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.3.1
    • 2.4.0
    • 2.4.1
    • 3.0.0
    • 3.1.0
    • 3.2.0
    • 3.2.1
    Affected ranges
    • GIT: < 0a8096adf165e2465550bd5893d7e352544e5967
    • ECOSYSTEM: < 3.2.2

    Update to 3.2.2

  • notebook PyPI

    Versions
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.0.4
    Affected ranges
    • GIT: < 9e63dd89b603dfbe3a7e774d8a962ee0fa30c0b5
    • ECOSYSTEM: ≥ 4.0.0, < 4.0.5

    Update to 4.0.5

Original sources

Check your server →