CVE-2015-7744
CVE-2015-7744
This page contains facts from public vulnerability sources. Check the original advisory before updating.
wolfSSL (formerly CyaSSL) before 3.6.8 does not properly handle faults associated with the Chinese Remainder Theorem (CRT) process when allowing ephemeral key exchange without low memory optimizations on a server, which makes it easier for remote attackers to obtain private RSA keys by capturing TLS handshakes, aka a Lenstra attack.
CVSS 5.9 · Medium · EPSS 5.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wolfssl Debian:12
- Affected ranges
- ECOSYSTEM: < 3.9.10+dfsg-1
Update to 3.9.10+dfsg-1
wolfssl Debian:13
- Affected ranges
- ECOSYSTEM: < 3.9.10+dfsg-1
Update to 3.9.10+dfsg-1
mariadb-5.5 Ubuntu:14.04:LTS
- Versions
- 5.5.32-1ubuntu1
- 5.5.35-1ubuntu1
- 5.5.36-1
- 5.5.37-0ubuntu0.14.04.1
- 5.5.39-0ubuntu0.14.04.1
- 5.5.40-0ubuntu0.14.04.1
- 5.5.41-0ubuntu0.14.04.2
- 5.5.41-1ubuntu0.14.04.1
- 5.5.43-1ubuntu0.14.04.2
- 5.5.44-1ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 5.5.46-1ubuntu0.14.04.2
Update to 5.5.46-1ubuntu0.14.04.2
mysql-5.5 Ubuntu:14.04:LTS
- Versions
- 5.5.32-0ubuntu7
- 5.5.34-0ubuntu1
- 5.5.34-0ubuntu2
- 5.5.35-0ubuntu1
- 5.5.35+dfsg-1ubuntu1
- 5.5.37-0ubuntu0.14.04.1
- 5.5.38-0ubuntu0.14.04.1
- 5.5.40-0ubuntu0.14.04.1
- 5.5.41-0ubuntu0.14.04.1
- 5.5.43-0ubuntu0.14.04.1
- 5.5.44-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 5.5.46-0ubuntu0.14.04.2
Update to 5.5.46-0ubuntu0.14.04.2
mysql-5.6 Ubuntu:14.04:LTS
- Versions
- 5.6.15-0ubuntu1
- 5.6.15-1~exp2
- 5.6.16-1~exp1
- 5.6.17-0ubuntu0.14.04.1
- 5.6.19-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 5.6.27-0ubuntu0.14.04.1
Update to 5.6.27-0ubuntu0.14.04.1
percona-xtradb-cluster-5.6 Ubuntu:16.04:LTS
- Versions
- 5.6.21-25.8-0ubuntu2
- 5.6.21-25.8-0ubuntu3
- 5.6.21-25.8-0ubuntu3.1
- 5.6.21-25.8-0ubuntu3.2
- Affected ranges
- ECOSYSTEM: < 5.6.34-26.19-0ubuntu0.16.04.1
Update to 5.6.34-26.19-0ubuntu0.16.04.1
percona-server-5.6 Ubuntu:16.04:LTS
- Versions
- 5.6.22-rel71.0-0ubuntu2
- 5.6.22-rel71.0-0ubuntu4
- 5.6.22-rel71.0-0ubuntu4.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00015.html
- http://www.securitytracker.com/id/1034708
- http://wolfssl.com/wolfSSL/Docs-wolfssl-changelog.html
- https://people.redhat.com/~fweimer/rsa-crt-leaks.pdf
- http://www.oracle.com/technetwork/topics/security/cpujan2016-2367955.html
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html
- https://wolfssl.com/wolfSSL/Blog/Entries/2015/9/17_Two_Vulnerabilities_Recently_Found%2C_An_Attack_on_RSA_using_CRT_and_DoS_Vulnerability_With_DTLS.html
- https://securityblog.redhat.com/2015/09/02/factoring-rsa-keys-with-tls-perfect-forward-secrecy/
- http://lists.opensuse.org/opensuse-security-announce/2016-02/msg00016.html
- https://nvd.nist.gov/vuln/detail/CVE-2015-7744