p PatchFirst

CVE-2015-7940

CVE-2015-7940

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Bouncy Castle Java library before 1.51 does not validate a point is withing the elliptic curve, which makes it easier for remote attackers to obtain private keys via a series of crafted elliptic curve Diffie Hellman (ECDH) key exchanges, aka an "invalid curve attack."

EPSS 4.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • bouncycastle Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.51-1

    Update to 1.51-1

  • bouncycastle Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.51-1

    Update to 1.51-1

  • bouncycastle Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.51-1

    Update to 1.51-1

  • bouncycastle Ubuntu:14.04:LTS

    Versions
    • 1.48+dfsg-2
    • 1.49+dfsg-2
    Affected ranges
    • ECOSYSTEM: < 1.49+dfsg-2ubuntu0.1

    Update to 1.49+dfsg-2ubuntu0.1

Original sources

Check your server →