p PatchFirst

CVE-2015-7975

CVE-2015-7975

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The nextvar function in NTP before 4.2.8p6 and 4.3.x before 4.3.90 does not properly validate the length of its input, which allows an attacker to cause a denial of service (application crash).

CVSS 6.2 · Medium · EPSS 0.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ntp Debian:11

    Affected ranges
    • ECOSYSTEM: < 1:4.2.8p7+dfsg-1

    Update to 1:4.2.8p7+dfsg-1

  • ntp Ubuntu:16.04:LTS

    Versions
    • 1:4.2.6.p5+dfsg-3ubuntu8
    • 1:4.2.6.p5+dfsg-3ubuntu8.1
    • 1:4.2.6.p5+dfsg-3ubuntu9
    • 1:4.2.8p4+dfsg-3ubuntu1
    • 1:4.2.8p4+dfsg-3ubuntu2
    • 1:4.2.8p4+dfsg-3ubuntu3
    • 1:4.2.8p4+dfsg-3ubuntu4
    • 1:4.2.8p4+dfsg-3ubuntu5
    • 1:4.2.8p4+dfsg-3ubuntu5.1
    • 1:4.2.8p4+dfsg-3ubuntu5.2
    Affected ranges
    • ECOSYSTEM: < 1:4.2.8p4+dfsg-3ubuntu5.3

    Update to 1:4.2.8p4+dfsg-3ubuntu5.3

Original sources

Check your server →