CVE-2015-8041
CVE-2015-8041
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Multiple integer overflows in the NDEF record parser in hostapd before 2.5 and wpa_supplicant before 2.5 allow remote attackers to cause a denial of service (process crash or infinite loop) via a large payload length field value in an (1) WPS or (2) P2P NFC NDEF record, which triggers an out-of-bounds read.
EPSS 3.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wpa Debian:12
- Affected ranges
- ECOSYSTEM: < 2.3-2.2
Update to 2.3-2.2
wpa Debian:13
- Affected ranges
- ECOSYSTEM: < 2.3-2.2
Update to 2.3-2.2
wpa Debian:14
- Affected ranges
- ECOSYSTEM: < 2.3-2.2
Update to 2.3-2.2
wpa Ubuntu:16.04:LTS
- Versions
- 2.4-0ubuntu3
- 2.4-0ubuntu4
- Affected ranges
- ECOSYSTEM: < 2.4-0ubuntu5
Update to 2.4-0ubuntu5
Original sources
- https://w1.fi/cgit/hostap/plain/hostapd/ChangeLog
- http://lists.opensuse.org/opensuse-updates/2015-11/msg00037.html
- https://w1.fi/cgit/hostap/plain/wpa_supplicant/ChangeLog
- http://www.securityfocus.com/bid/75604
- http://lists.opensuse.org/opensuse-updates/2015-11/msg00041.html
- http://www.openwall.com/lists/oss-security/2015/11/02/5
- http://www.debian.org/security/2015/dsa-3397
- http://w1.fi/security/2015-5/incomplete-wps-and-p2p-nfc-ndef-record-payload-length-validation.txt
- https://nvd.nist.gov/vuln/detail/CVE-2015-8041