p PatchFirst

CVE-2015-8126

CVE-2015-8126

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Multiple buffer overflows in the (1) png_set_PLTE and (2) png_get_PLTE functions in libpng before 1.0.64, 1.1.x and 1.2.x before 1.2.54, 1.3.x and 1.4.x before 1.4.17, 1.5.x before 1.5.24, and 1.6.x before 1.6.19 allow remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a small bit-depth value in an IHDR (aka image header) chunk in a PNG image.

EPSS 10.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libpng Ubuntu:14.04:LTS

    Versions
    • 1.2.49-4ubuntu1
    • 1.2.49-5ubuntu1
    • 1.2.50-1ubuntu1
    • 1.2.50-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1.2.50-1ubuntu2.14.04.1

    Update to 1.2.50-1ubuntu2.14.04.1

Original sources

Check your server →