p PatchFirst

CVE-2015-8158

CVE-2015-8158

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The getresponse function in ntpq in NTP versions before 4.2.8p9 and 4.3.x before 4.3.90 allows remote attackers to cause a denial of service (infinite loop) via crafted packets with incorrect values.

CVSS 5.9 · Medium · EPSS 7.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • ntp Debian:11

    Affected ranges
    • ECOSYSTEM: < 1:4.2.8p7+dfsg-1

    Update to 1:4.2.8p7+dfsg-1

  • ntp Ubuntu:14.04:LTS

    Versions
    • 1:4.2.6.p5+dfsg-3ubuntu2
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.1
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.2
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.3
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.5
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.6
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.7
    • 1:4.2.6.p5+dfsg-3ubuntu2.14.04.8
    Affected ranges
    • ECOSYSTEM: < 1:4.2.6.p5+dfsg-3ubuntu2.14.04.10

    Update to 1:4.2.6.p5+dfsg-3ubuntu2.14.04.10

  • ntp Ubuntu:16.04:LTS

    Versions
    • 1:4.2.6.p5+dfsg-3ubuntu8
    • 1:4.2.6.p5+dfsg-3ubuntu8.1
    • 1:4.2.6.p5+dfsg-3ubuntu9
    • 1:4.2.8p4+dfsg-3ubuntu1
    • 1:4.2.8p4+dfsg-3ubuntu2
    • 1:4.2.8p4+dfsg-3ubuntu3
    • 1:4.2.8p4+dfsg-3ubuntu4
    • 1:4.2.8p4+dfsg-3ubuntu5
    • 1:4.2.8p4+dfsg-3ubuntu5.1
    • 1:4.2.8p4+dfsg-3ubuntu5.2
    Affected ranges
    • ECOSYSTEM: < 1:4.2.8p4+dfsg-3ubuntu5.3

    Update to 1:4.2.8p4+dfsg-3ubuntu5.3

Original sources

Check your server →